Blog / Rides

Posted on 12 August 2015 at 12:04 am (CET)
Category: Electric motor, Rides
Posted on 12 August 2015 at 12:04 am (CET)
Category: Electric motor, Rides

After making a few modifications the motor gets cooled a little better now. The motor doesn't get warm as quickly now and when standing still the temperature drops rather quick. But still the motor does get a little too warm after riding for a while, even on continuous power.

First modification is 3 fans right below the motor, these blow air from below through the motor. For testing I just attached them with some velcro.

E-Streetquad Motor cooling improved


E-Streetquad Motor cooling improved


I just have the idea that it doesn't really work that great while driving since the airflow is probably pushing all of the air out of the way. So I'll have to close this off a bit with some kind of air intake on the bottom, should work a bit better then. I also ordered the wrong fans, these don't have enough airflow. I've now ordered some that have double the airflow and are a little bigger.

The second modification is a hole in the protective cover of the motor. I just placed a hose on there with the in-line blower. This one sucks the hot air out of the brush area.

E-Streetquad Motor cooling improved


E-Streetquad Motor cooling improved


This seems to be working pretty well, just makes a lot of noise. But even like this the motor still gets a bit too warm (73 degrees celsius on continuous power). I could still try to turn around the in-line blower to push air into the motor. Just still have to add an air filter then.

But at least for testing I can now ride a bit longer distance. I've done this a few times already. Here's a video again of last weekend. Went out for a ride in the evening, came across 3 very nice classic cars just within 15 minutes of riding time. Also did one more lap in the dark, thought that was pretty amazing. :)

Posted on 7 August 2015 at 08:56 pm (CET)
Category: Electric motor, Rides
Posted on 7 August 2015 at 08:56 pm (CET)
Category: Electric motor, Rides

This update is a little bit late but I needed some time to edit the video. Last weekend I finally had a lot of fun with the first few road legal runs. They were just still test runs though since the problem with the motor temperature is still present. In the beginning I could barely make 2 laps around town (1 small and 1 bigger lap) before the motor got to 85 degrees celsius. I'll keep doing these 2 laps for testing, that way it's easy to see if there's any improvements after making some changes. Only when I'm satisfied I'll go try a longer distance.

Here are some pictures before I rode off. You can also see something new, I placed daytime running lights right below the headlights. I'm still not sure if I'll keep it this way but for now I'm liking it.

E-Streetquad First few road legal test runs


For the parking lights, low beam and high beam I also have different lights, the light on these is a bit more white than the standard ones that were in there.

E-Streetquad First few road legal test runs


First I tried removing the protective cover from the motor, this way the heat of the carbon brushes can escape. Ofcourse it won't stay like this, there's voltage on all of it while riding. But for testing it's necessary for now.

E-Streetquad First few road legal test runs


In the evening I went for another 2 laps. The difference was definately noticeable, ended up with 75 degrees celsius, already 10 degrees less. So it's clear that most of the heat has to be removed from this area. Another few pictures before I rode off.

E-Streetquad First few road legal test runs


E-Streetquad First few road legal test runs


When I returned it was already getting a bit dark, nice picture for the lights. And again you can see something I added, a second brake light in the top case. I could barely fit a whole LED strip in there and it's quite well visible. I think it's also safer since the rear light is always on. It's sometimes hard to see the brake light then, but like this it's always clear to see when I'm braking.

E-Streetquad First few road legal test runs


After these runs one thing is pretty obvious, the motor will need active cooling one way or another. The bottom of the motor and swing arm is wide open so that would be a good place to pass air through.

E-Streetquad First few road legal test runs


There's also plenty of space below the swing arm.

E-Streetquad First few road legal test runs


What I've already tried is leading an air hose to the front so wind will be caught in it and blown through the motor.

E-Streetquad First few road legal test runs


This just didn't seem to make a lot of difference, I think the opening of the air hose is just too small for it. I have now added an in-line blower and filter which constantly blows air through the motor.

E-Streetquad First few road legal test runs


The motor does get a little bit less warm now while riding and it also cools down faster when standing still. But I'm still not satisfied. I now want to try placing 3 fans right below the swing arm and using the in-line blower to extract hot air from the brush area to the rear. Don't think I can do any more than that, so I hope it'll work like that. I'm just waiting for the parts now so I probably won't be able to continue with it untill next week.

All runs I did I have filmed again, I tried with the camera on the helmet now and not on the quad bike itself and also with 60 fps instead of 30. Not very exciting yet but these still are the first few road legal kilometers.


Soon hopefully some longer runs once the cooling for the motor is on there.

Posted on 15 March 2015 at 07:03 pm (CET)
Category: General, Rides
Posted on 15 March 2015 at 07:03 pm (CET)
Category: General, Rides

You don't have to wait any longer, I will now show what the quad bike looks like after working on it for almost 2,5 years. I'm really happy that I chose these colors, everything matches really good and it just looks really great. When I started this project I did have an idea of how I wanted it but it's become even better than I expected. Well, here it is. :)

E-Streetquad Quad bike revealed and third test ride at high speed


E-Streetquad Quad bike revealed and third test ride at high speed


E-Streetquad Quad bike revealed and third test ride at high speed


Ofcourse it's nice that it all looks so good but what's more important is that it did really good again during the third test ride yesterday. This time I went to the industrial area again where my sister works, there's a nice long road there with a dead end so there's not much traffic. I've only tested at high speed now, mainly to see if the motor would get as warm again. This past week I've ran the motor for 12,5 hours at 1000 RPM so the brushes should be seated by now.

But unfortunately it already got too warm again (90 degrees celsius) just after going up and down the road twice in Sport mode. Meanwhile I did reach a new top speed of 84,7 km/h (52,6 mph) though. And it should be able to go a little faster. I think 88-90 km/h (54-56 mph) should be possible. Which is good as that's exactly the speed I had in mind when I selected the sprockets. It rides a lot better as well now, it's fitted with 4 new tyres (Toyo Proxes T1-R) and the wheels have been balanced. You can really notice the difference is at high speed.

After the motor got so warm I only still tested on Eco mode. Was a bit less fun but necessary to see if the motor would still get warm with just half the power. This is also the nominal power which the motor should be able to run at continuously. While it did take a bit longer it unfortunately still got to 85 degrees celsius after going up and down the road 6 times. So something is not right and I already have a few ideas what could be causing it. I'll look into this in the coming days.

Another problem is that the gauge which shows me voltage and current has broken for the second time. And not even during the test ride but just here at home while I was charging the quad bike a bit. I don't really have any faith in it anymore so I'll be replacing it with a different one. I'll just have to take a few fenders off again but this just needs to work properly for the road approval test.

But for the rest I'm very satisfied, the quad bike is working just fine and on Sport mode it's a real pleasure to ride on it. Ofcourse I made another video again so you can see it all as well. :)


Just a few more modifications and then on to the RDW. ;)

Posted on 1 March 2015 at 12:58 pm (CET)
Category: Rides
Posted on 1 March 2015 at 12:58 pm (CET)
Category: Rides

Yesterday I went testing for the second time. First I went to a boatyard's parking lot nearby. Usually you can drive all the way around but since the water was high this unfortunately wasn't possible now. But the asphalt also wasn't as good as I thought, because of this it turned out to be a good test to check if any bolts or nuts would still come loose though. ;)

E-Streetquad Second test ride with some more power


I rode around here for a while and it was very fun again. Could really notice that I had a lot more power now than during the last test. Acceleration was much quicker now. But I still don't think I had the full power. The highest I've seen is 315 A while everything is set up for 400 A. But I also couldn't keep looking at the gauge the whole time since I had to keep looking where I was riding. For the next test I'll just place the camera in front of it, then I can at least see everything at home.

But everything went well, nothing came loose anymore and nothing broke either. The temperature sensor in the motor is working fine as well. Only problem was that the motor got pretty warm quickly and I had to let it cool off a few times. It's probably because the brushes aren't properly seated yet so I'll just have to wait and see. On the parking lot I also couldn't really reach a high speed and was really only accelerating and braking the whole time. So I left there and since I couldn't resist I did a few quick runs on the road. :)

E-Streetquad Second test ride with some more power


The real fun started here since this was actually the first time at higher speed. The quad bike again did very well here, it all felt great and it just kept accelerating nicely. It definately has more than enough power. First I tested at low power (Eco mode) so the motor wouldn't get so warm right away. Accelerates less quickly then but on that road I was able to get up to 75 km/h (46 mph).
But I knew that it could do more so after that I tested again but this time at high power (Sport mode). I reached 75 km/h (46 mph) very quickly now and was able to get a maximum speed of 82,6 km/h (51 mph). That was pretty much the goal of this test, getting above 80 km/h (50 mph) for the first time. And that has also succeeded. :)

In total I rode almost 10 km (6 miles) again, so the same as the last test. Only the ride time was a bit less this time since the quad bike was much faster now. ;) Only thing I need to keep an eye on for now is the temperature of the motor, at the moment this is getting a bit too high.

E-Streetquad Second test ride with some more power


Ofcourse I brought the cameras with me again and made a video again. Think you can see really good that the quad bike has more power now. :)


This coming week I'll order the new tyres so the Chinese tyres can go off. And I'll also completely finish the quad bike by adding the fenders on. I'll probably test once more before I go the RDW but for now it's all looking good. If I don't run into any problems anymore during the next test then I also don't really expect any problems at the RDW. It'll definately be very exciting.

Posted on 1 February 2015 at 10:09 pm (CET)
Category: Rides
Posted on 1 February 2015 at 10:09 pm (CET)
Category: Rides

So yesterday I was finally able to have a test ride on the quad bike after a bit more than 2 years of working on it. It was a really great experience. Even though I started with very little power I already really enjoyed it. I didn't test it anywhere close here but at the place where my sister works and on a short road. So I had to get the quad bike on the trailer here at home first. It all went well but I'm going to make some modifications to the ramps since I don't think they're very safe. But after half an hour the quad bike was stuck on there and I could drive off.

E-Streetquad First test ride at half and full power


Thankfully I also arrived safely at the place where I could test.

E-Streetquad First test ride at half and full power


Not too long after that I rode the quad bike off it and started testing at half power. Looking back at it I'm not even sure if that was actually half power, I think it was more like 1/8th of the power. I didn't see more than 50 A while 200 A should have been possible at half power. But it was pretty fun already and a good way to get to know the quad bike a bit.

Then I changed the controller settings a few times to be able to get full power. The acceleration did feel a bit faster but on the gauge I still didn't see much of a difference compared to half power. Unfortunately during these tests the DC-DC converter passed away which resulted in quite an exciting moment. I was just riding around the corner when suddenly all power was gone, the rear wheels slipped a little. :)

Thankfully I was still able to continue after that since I took an extra 12 V battery with me. Placed this in the top case and connected it, it just barely fit. After that the quad bike worked perfectly again. But still I didn't quite feel and see the power that I actually should be getting. The top speed at that moment was around 45 km/h and the motor was also running at a bit less than half RPM. So I was pretty sure that something wasn't right. I even used my phone to check the speed with GPS and my sister rode her scooter right next to me. But the speed was actually right.

To be sure I checked the controller settings again. I just changed one thing and tried again. Right away when I took off I felt that it was all good now, I suddenly had much more power. So the controller settings were just wrong all this time, it was not giving the full power to the motor but holding back instead. I also did see on my gauge that it was going above 100 A now. So after that I lowered that same setting again and I was suddenly reaching 250 A. So much power suddenly, it was really amazing. I was just riding with a big smile on my face the whole time now. Also tried a bit on the short road again and the quad bike just kept pulling. I just had to get on the brakes every time I hit 60 km/h since the road wasn't longer. But I'm sure that 85-90 km/h is definately possible with the current gearing. And I wasn't even at full power yet so the acceleration will also only get better once I find the right setting.

After that I still did 2 quick runs on the lot but then I called it a day. The quad bike really has a lot of grip even though the ground was quite damp, also really nice to ride on. Was quite exiting too since it was actually the first time riding a quad bike and also the first time on/in an electric vehicle. But as it turns out I love both and I really cannot wait untill I'm allowed to go onto the roads legally with it. :D I just did notice that the tires aren't really that great, I'll be replacing these with some good quality tires soon.

But after this whole story you all just want to see one thing ofcourse and that's the video. ;) So here it is. In the beginning it might be a bit boring but in the end you can really see the difference in power. You can even hear it while there's not really much noise coming from it. :D


My sister also still filmed a bit. Most of it is at low power as well, just from a different view. The last minute is with more power but is pretty much the same as in the video above, but my sister was also standing in the same spot. :)


Unfortunately the onboard camera was already empty fast and the other camera's memory was also full quite fast so there's not as much footage with more power. But it'll be alright, maybe I'll try again soon and then not forget to take my laptop with me. Then I can see all the data of the controller while riding and see why exactly the full power is not reaching the motor.